Investigating an issue with placing orders through the app
Major incident
Europe
Mobile App
North America
Australia
2024-08-26 10:30 CEST
· 1 hour, 44 minutes
Updates
Resolved
August 26, 2024 · 12:29 CEST
The issue affecting order placement through the app has been resolved. Services are now operating normally. We apologise for any inconvenience caused. Please reach out if you continue to experience issues.
Issue
August 26, 2024 · 11:47 CEST
We are currently investigating an issue with placing orders through the app. Our team is actively working on resolving the issue and will provide updates here.
← Back