Operational issue – Multiple services (North America)
Major incident
Website
MyStore
Mobile App
North America
North America
2025-10-20 09:00 CEST
· 2 hours, 33 minutes
Updates
Resolved
October 20, 2025 · 11:32 CEST
We are seeing significant signs of recovery. Most requests should now be succeeding.
Issue
October 20, 2025 · 11:15 CEST
Our cloud provider is having issues in the North America region causing downtime in US and CA. We are monitoring the situation closely.
← Back